Présentation

Créé avec HelpNDoc Personal Edition: Créer des sites web d'aide facilement

Copyright © 2012-2014, Bernard Ribot


? - Affiche le fichier d'aide

Le fichier d'aide s'affiche dans une fenêtre séparée. La fenêtre d'exécution du script devient quand à elle inactive. Il faut donc la réactiver (en cliquant dans le titre) pour continuer de travailler.

Pour signaler un bug ou suggérer une amélioration, envoyez un mail à contact@ribot-online.fr.

Créé avec HelpNDoc Personal Edition: Création d'aide CHM, PDF, DOC et HTML d'une même source


Prérequis

Le script exécute les logiciels suivants :

  • Ccleaner et Ccleaner Enhancer
  • Malwarebytes AntiMalware
  • Smart Defrag
  • Wise Registry Cleaner

Ainsi que les commandes Windows suivants :

  • fsutil
  • chkdsk
  • cleanmgr

Créé avec HelpNDoc Personal Edition: Générateur complet de livres électroniques ePub


Ccleaner et Ccleaner Enhancer

Prérequis ››

Si Ccleaner n'est pas déjà installé, aller sur http://ribot-online.fr pour télécharger la dernière version.

Ccleaner Enhancer est une extension pour Ccleaner qui ajoute le nettoyage d'un certain nombre de logiciels non présents dans Ccleaner : elle va nous permettre, entre autres, de nettoyer Windows Media Player, de supprimer les rapports de Malwarebytes' AntiMalware.

Aller sur http://ribot-online.fr pour télécharger la dernière version et exécuter ccenhancer-n.n.exe (n.n représente le numéro de version) et dans la fenêtre cliquer sur [Download Latest].

Créé avec HelpNDoc Personal Edition: Créer des documents d'aide facilement


Malwarebytes AntiMalware

Prérequis ››

L'utilisation de Malwarebytes' AntiMalware en ligne de commande en mode « silencieux » nécessite la version enregistrée.

Si MBAM n'est pas déjà installé, télécharger la dernière version sur http://ribot-online.fr .

Lancer Malwarebytes' AntiMalware. En bas de la fenêtre principale cliquer sur [Enregistrer].

Dans la mesure où un logiciel assure déjà cette protection (Kaspersky Internet Security, Windows Defender ou autres) décocher la case « Activer le module de protection ».

Entrer les codes suivants :

ID=6RU57

KEY=AEYM-A0KU-GCLQ-RU87

Créé avec HelpNDoc Personal Edition: Créer des livres électroniques facilement


Smart Defrag

Prérequis ››

Si Smart Defrag n'est pas déjà installé, aller sur http://ribot-online.fr pour télécharger la dernière version.

Créé avec HelpNDoc Personal Edition: Générateur de documentations PDF gratuit


Wise Registry Cleaner

Prérequis ››

Si Wise Registry Cleaner n'est pas déjà installé, télécharger la dernière version sur http://ribot-online.fr .

Créé avec HelpNDoc Personal Edition: Générateur de documentation complet


A - Lancement Ccleaner (GUI)

Si le logiciel est installé le script lance l'interface graphique (GUI) de Ccleaner.

Créé avec HelpNDoc Personal Edition: Générer des livres électroniques EPub facilement


B - Nettoyage disques avec Ccleaner

Le script lance Ccleaner en mode « silencieux » pour effectuer le nettoyage des disques du PC selon les paramètres préalablement définis dans Ccleaner Nettoyeur, onglets Windows et Applications.

Cette fonction nécessite des droits d'administrateur [1].

[1] C'est-à-dire que le script doit être exécuté dans un compte administrateur.

Créé avec HelpNDoc Personal Edition: Générateur complet de livres électroniques ePub


C - Nettoyage répertoire Temp de l'utilisateur et divers dossiers et fichiers

Supprime tous les fichiers et dossiers du répertoire Temp de l'utilisateur (dossier ..\AppData\Roaming\Temp du compte sous lequel est exécuté le script).

Certains fichiers et dossiers en cours d'utilisation ne pourront être supprimés.

Cette option supprime également :

- les compte-rendus créés par Adwcleaner (fichiers C:\Adwcleaner\Adwcleaner[xx].txt),

- les dossiers créés dans le dossier Mes documents par Freemake Video Converter et nommés Freemake_do_not_remove_this_folder*

- les sauvegardes du registre créées par Ccleaner (fichier de la forme cc_*.reg).

Créé avec HelpNDoc Personal Edition: Générateur d'aide complet


D - Nettoyage fichiers système et dossier winsxs

Le nettoyage des fichiers système et du dossier winsxs s'effectue à l'aide du module Windows cleanmgr.exe.

L'opération est réalisée en 2 phases :

1. Il faut préalablement définir l'ensemble des options de nettoyage dans la base de registre Cette opération ne s'effectue qu'une seule fois à l'aide d'un script d'exécution du module cleanmgr.exe.

2. Le nettoyage lui-même est réalisé également par un script d'exécution de cleanmgr.exe

Attention : les scripts doivent être exécutés en tant qu'administrateur.

Paramétrage

Nettoyage

Créé avec HelpNDoc Personal Edition: Générateur gratuit de livres électroniques et documentation


Paramétrage

D - Nettoyage fichiers système et dossier winsxs ››

Cette option lance l'exécution de cleanmgr.exe avec le commutateur /sageset qui permet l'enregistrement des options dans la base de registre.

Dans la fenêtre "Réglages du Nettoyage de disque" cochez les options suivantes, si elles ne sont pas cochées :

- Temporary setup files

- Fichiers programmes téléchargés

- Fichiers internet temporaires

- Anciens fichiers Chkdsk

- Fichiers de vidage mémoire d'erreurs système
- Fichiers de minividage d'erreurs système
- Fichiers temporaires

- Miniatures

- Nettoyage de Windows Update

Cliquez sur [OK]. L'ensemble des options choisies sera enregistré dans la BdR.

Ceci n'est à faire qu'une seule fois.

Créé avec HelpNDoc Personal Edition: Éditeur complet de livres électroniques ePub


Nettoyage

D - Nettoyage fichiers système et dossier winsxs ››

Cette option lance l'exécution de cleanmgr.exe avec le commutateur /sagerun qui permet d'exécuter cleanmgr avec les options enregistrées dans la BdR.

Lors de l'exécution ces 2 fenêtres seront affichées :

Étape 1 - calcul de l'espace disque à récupérer

Étape 2 - suppression des fichiers :

L'espace libéré sera réellement disponible au prochain démarrage de Windows.

Créé avec HelpNDoc Personal Edition: Créer des documents d'aide facilement


E - Lancement Smart Defrag (GUI)

Exécution de Smart Defrag avec affichage de l'interface graphique utilisateur (GUI).

ATTENTION : Si votre disque système C: est un disque SSD, décochez la case correspondante, ne cochez que les cases correspondantes à votre autre disque (par exemple : disqu D: ou F:) :

Cette fonction nécessite des droits d'administrateur.

Remarque : cette option n'est en principe pas nécessaire, sauf cas particulier, Smart Defrag étant installé pour s'exécuter en permanence en tâche de fond et réaliser automatiquement la défragmentation des disques selon les critères définis lors de sa configuration.

Créé avec HelpNDoc Personal Edition: Créer des aides HTML, DOC, PDF et des manuels depuis une même source


F - Défragmentation des disques de sauvegarde (S: et/ou T:)

Les lettres de lecteur S: et T: ont été attribuées aux disques externes de sauvegarde. Ces disques ne sont généralement pas en ligne et ne sont donc pas pris en charge par Smart Defrag. Bien moins fragmentés que les disques système (généralement C:) ou de données (D:, F:, I:, J: selon les installations) il convient toutefois de procéder de temps en temps à une défragmentation.

Au lancement de l'option un message vous invite à mettre le(s) disque(s) de sauvegarde sous tension. Ensuite la défragmentation du disque S: est lancé (s'il est monté), puis celle du disque T: (s'il est monté).

Le processus de défragmentation s'effectue dans une autre fenêtre.

L'intégrité des disques est vérifiée avant toute défragmentation. S'il s'avérait qu'un disque n'était pas intègre vous serez invité à lancer une réparation en utilisant l'option G.

Cette fonction nécessite des droits d'administrateur

Créé avec HelpNDoc Personal Edition: Générateur de documentation complet


G - Vérification et réparation disque C: avec CHKDSK

Le script vérifie préalablement si le disque C: est intègre. Si le disque C: n'est pas intègre le script lance une commande CHKDSK pour réparer les secteurs défectueux et tenter de récupérer les données.

CHKDSK demande une confirmation, auquel cas il sera exécuté au redémarrage du PC (CHKDSK ne peut être exécuté sur le disque C: - disque système - lorsque Windows est démarré).

Cette option ne peut pas être utilisée si votre disque système C: est un disque SSD.

Cette fonction nécessite des droits d'administrateur

Créé avec HelpNDoc Personal Edition: Générateur de documentation d'aide HTML gratuit


H - Vérification et réparation autres disques avec CHKDSK

Le script recherche les autres disques fixes du PC. Pour chacun des disques trouvés il vérifie préalablement si le disque est intègre. Si le disque n'est pas intègre le script lance une commande CHKDSK pour réparer les secteurs défectueux et tenter de récupérer les données.

Cette fonction nécessite des droits d'administrateur

Créé avec HelpNDoc Personal Edition: Générateur de documentation et EPub facile


I - Nettoyage registre avec Wise Registry Cleaner

Si le logiciel est installé, le script lance Wise Registry Cleaner en mode « silencieux », pour effectuer le nettoyage du registre.

Il est fortement conseillé de configurer Wise Registry Cleaner de manière à ce qu'une sauvegarde du registre soit effectuée avant le nettoyage. Dans l'onglet Options la case "Sauvegarde auto ..." doit être cochée :

.

Wise Registry Cleaner enregistre la sauvegarde en :

" C:\Users\<user>\AppData\Roaming\Wise Registry Cleaner\backup ".(sous Windows Vista/7) ou

" C:\Documents and settings\<user>\Wise Registry Cleaner\backup " (sous Windows XP).

Dans les paramètres d'exécution de Wise Registry Cleaner dans le script, le choix a été fait d'utiliser le mode "safe" c'est-à-dire que seules les entrées qui peuvent être supprimées sans risque sont supprimées.

Cette fonction nécessite des droits d'administrateur

Créé avec HelpNDoc Personal Edition: Générateur complet de livres électroniques ePub


J - Lancemant Wise Registry Cleaner (GUI)

Si le logiciel est installé le script lance l'interface graphique (GUI) de Wise Registry Cleaner.

La fonction de défragmentation du registre ne peut être exécutée en mode "silencieux". Pour procéder à la défragmentation, lancez l'interface graphique de Wise Registry Cleaner et ouvrir l'onglet Défragmentation et cliquer sur [Analyser] :

Selon le résultat de l'analyse Wise Registry Cleaner vous recommande ou non de défragmenter le registre :

Si le message "Une défragmentation du registre est nécessaire" cliquez sur [Défragmenter].

L'ordinateur sera redémarré après la défragmentation.

Cette fonction nécessite des droits d'administrateur

Créé avec HelpNDoc Personal Edition: Générateur de documentation et EPub gratuit


K - Scan rapide avec Malwarebytes Anti-Malware

Exécute Malwarebytes' AntiMalware en mode "silencieux" pour exécuter un scan rapide.

En mode "silencieux" seules les menaces critiques sont éliminées.

Cette fonction nécessite des droits d'administrateur

Créé avec HelpNDoc Personal Edition: Produire des livres électroniques facilement


L - Scan complet avec Malwarebytes Anti-Malware

Exécute Malwarebytes' AntiMalware en mode "silencieux" pour exécuter un scan complet.

En mode "silencieux" seules les menaces critiques sont éliminées.

Cette fonction nécessite des droits d'administrateur

Créé avec HelpNDoc Personal Edition: Générateur de documentation iPhone gratuit


M - Lancement de Malwarebytes Anti-Malware (GUI)

Lance l'interface graphique (GUI) de Malwarebytes' Anti-Malware.

Cette fonction nécessite des droits d'administrateur

Créé avec HelpNDoc Personal Edition: Créer des livres électroniques EPub facilement